Thanks, I wasn't sure when () were needed and when not. Having simple rules as below is very beneficial. I will add to my notes.
About styles, I see how you and Peter came up with your style because you guys do assembly programming and work in plain text editors.
In viewing code in just black and white with no color highlighting, your style makes sense and is easier to read.
I find that when you use assembly style with highlighted syntax it is very hard to read.
I think the indented, 4 spaces, with highlighted syntax looks nice and is easy to read. Since I was using c++ the last 2 years or more
I got used to naming things differently because of case matters. I do prefer programming in case doesn't matter languages like BASIC,
but have to get used to it again.
I would hold off on an established style till we do some more real world classes to see what we come up against. As you saw, I came up
with a different naming scheme for variables than what we started out with. Will need to see how it works with other classes.
I will work on glSimpleWindowClass more today to see if I can get it working with your new tips. I also found a nice sub you have
in minwin for deleting libraries, so I changed my code to use that. So no more freelibrary in the class code, I call your sub and noted it in the code.